Bohužel bývá forum stále častěji napadeno a zaplněno SPAMem. Nemám čas tyto situace řešit, takže jsem momentálně vypnul možnost registrací. Promazání posledních SPAMů asi nedopadlo korektně, takže se některé příspěvky nezobrazují správně.

BGP a OSPF nekomunikuje - Help

Síťové topologie, kreslení různých schémat sítí

BGP a OSPF nekomunikuje - Help

Příspěvekod StoneCZE » 17.08.2014 10:50

Dobrý den,

zkouším si konfiguraci eBGP a iBGP (ted řesím že mi nefunguje eBGP, topologii mám větší)

topologie,
Obrázek

- mezi R1 (AS100) a R2 (AS200) mám nastaveno BGP. Nejde mi ale se pingnou z PC linux3 na PC linux5.
- z oboutechto PC se lze v pohode pingnout po sve siti, kde je nastaveno OSPF (tzn. linux 3 se pinge na Lo R1, a linux5 se pingne na Lo R2)
- ping ale neprojde dál
- si mi zda ze OSPF nejak nekomunikuje s BGP. Ze OSPF nevi ze to ma predat BGP a nevim co s tim mam delat. poradi mi nekdo pls?
- chybi tam asi nejaky radek nebo dva konfigurace, ale nemuzu prijit jaka :(

R1:
Obrázek

Show run:
interface Loopback0
ip address 10.10.10.10 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 192.168.3.2 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.0.0.1 255.255.255.252
clock rate 2000000
.
.
router ospf 1
log-adjacency-changes
!
router bgp 100
bgp log-neighbor-changes
neighbor 10.0.0.2 remote-as 200
!
address-family ipv4
redistribute ospf 1 match internal external 1 external 2
neighbor 10.0.0.2 activate
no auto-summary
no synchronization
network 10.10.10.10 mask 255.255.255.255
network 192.168.3.0
exit-address-family



R2:

Obrázek

Show run:
interface Loopback0
ip address 10.10.10.11 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 10.2.2.1 255.255.255.252
ip ospf 1 area 0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.0.0.2 255.255.255.252
clock rate 2000000
.
.
router ospf 1
log-adjacency-changes
!
router bgp 200
bgp log-neighbor-changes
neighbor 10.0.0.1 remote-as 100
neighbor 10.4.4.2 remote-as 200
!
address-family ipv4
redistribute ospf 1 match internal external 1 external 2
neighbor 10.0.0.1 activate
neighbor 10.4.4.2 activate
no auto-summary
no synchronization
network 10.10.10.11 mask 255.255.255.255
network 192.168.5.0
exit-address-family
!

Pomuze nekdo najit chybu?
StoneCZE
nováček
nováček
 
Příspěvky: 1
Registrován: 17.08.2014 10:25

Re: BGP a OSPF nekomunikuje - Help

Příspěvekod cromac » 25.08.2014 08:17

Cau,

jak vypada routovaci tabulka R7? Nevidim na R2 zadnou redistribuci BGP do OSPF ani tam nesiris default routu. Redistribuce OSPF do BGP funguje tak jak ma, to je videt z BGP i routing table na jednotlivych routrech.

Cromac
cromac
mistr
mistr
 
Příspěvky: 100
Registrován: 06.05.2010 13:37


Zpět na Topologie a schémata sítí

Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 2 návštevníků